Saturday, July 5, 2014

Lab 1 - BGP Peering

Teaching is the best form of learning, so I will be using this blog and other venues to post my thoughts on topics related to the CCIE R & S lab exam to help me, and hopefully others, through the long journey of studying and learning to prepare for the lab exam. So to begin I'm starting with a core technology BGP and from the beginning.

I hope to create a series of real labs that teach specific topics for the lab based on the version 5 blueprint. So to begin I've started with a basic concept in BGP, establishing neighbors.

Concepts tested
  • Establishing iBGP Peerings
  • Establishing EBGP Peerings
  • BGP Update Source Modification
  • Multihop EBGP Peerings
  • Neighbor Disable-Connected-Check
  • Authenticating BGP Peerings

Complete the following tasks:
  • Establish an iBGP peering between R2 and R3 using their loopback 0 interfaces
  • Advertise R2 and R3's loopback 10-13 into BGP
  • Establish an eBGP peering between R1 and R2 and R1 and R3. Ensure that even if the serial1/0 link on R2 goes down the peering between R1 and R2 stays up. You cannot modify the TTL settings (no ebgp-multihop command) for the peering between R1 and R2 to accomplish this but you can between R1 and R3.
  • Establish an eBGP secure peering between R3 and R4 using the password CISCO1

Topology used
Lab 1

GNS3 configuration file, requires IOS v15 for the 7200 router: Link


Solution Below:

1.       Establish an iBGP peering between R2 and R3 using their loopback 0 interfaces

R2(config)#router bgp 200
R2(config-router)#neighbor 3.3.3.3 remote-as 200
R2(config-router)#neighbor 3.3.3.3 update-source loopback 0

R3(config)#router bgp 200
R3(config-router)#neighbor 2.2.2.2 remote-as 200
R3(config-router)#neighbor 2.2.2.2 update-source loopback 0

Verify:

R2#sh ip bgp summary
<snip>
Neighbor        V           AS        MsgRcvd MsgSent   TblVer  InQ OutQ  Up/Down    State/PfxRcd
3.3.3.3             4          200       4               4                1            0     0          00:00:14      0

R3#sh ip bgp summary
<snip>
Neighbor        V           AS        MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2             4          200      11              8                9            0     0         00:03:44        0

2.       Advertise R2 and R3's loopback 10-13 into BGP

R2(config)#router bgp 200
R2(config-router)#network 172.16.0.0 mask 255.255.255.0
R2(config-router)#network 172.16.1.0 mask 255.255.255.0
R2(config-router)#network 172.16.2.0 mask 255.255.255.0
R2(config-router)#network 172.16.3.0 mask 255.255.255.0

R3(config)#router bgp 200
R3(config-router)#network 172.16.4.0 mask 255.255.255.0
R3(config-router)#network 172.16.5.0 mask 255.255.255.0
R3(config-router)#network 172.16.6.0 mask 255.255.255.0
R3(config-router)#network 172.16.7.0 mask 255.255.255.0

Verify:

R2#sh ip bgp
<snip>
   Network          Next Hop            Metric LocPrf Weight Path
*> 172.16.0.0/24    0.0.0.0                  0         32768 i
*> 172.16.1.0/24    0.0.0.0                  0         32768 i
*> 172.16.2.0/24    0.0.0.0                  0         32768 i
*> 172.16.3.0/24    0.0.0.0                  0         32768 I

R3#sh ip bgp
<snip>
   Network          Next Hop            Metric LocPrf Weight Path
*>i172.16.0.0/24    2.2.2.2                  0    100      0 i
*>i172.16.1.0/24    2.2.2.2                  0    100      0 i
*>i172.16.2.0/24    2.2.2.2                  0    100      0 i
*>i172.16.3.0/24    2.2.2.2                  0    100      0 i

3.       Establish an eBGP peering between R1 and R2 and R1 and R3. Ensure that even if the serial1/0 link on R2 goes down the peering between R1 and R2 stays up. You cannot modify the TTL settings (no ebgp-multihop command) for the peering between R1 and R2 to accomplish this but you can between R1 and R3.

R2(config-router)#neighbor 1.1.1.1 remote-as 100
R2(config-router)#neighbor 1.1.1.1 update-source loopback 0
R2(config-router)#neighbor 1.1.1.1 disable-connected-check

R1(config-router)#neighbor 2.2.2.2 remote-as 200
R1(config-router)#neighbor 2.2.2.2 update-source loopback 0
R1(config-router)#neighbor 2.2.2.2 disable-connected-check

The disabled-connected-check command disables the code in IOS BGP that verifies if two eBGP peers are directly connected. Technically this check is what prevents eBGP peering with loopback connections between directly connected hosts not the TTL.


Verify R1 to R2:

R2#sh ip bgp sum
<snip>
Neighbor        V           AS       MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
1.1.1.1         4              100      24            26               9           0       0       00:18:46        0


R1#sh ip bgp sum
<snip>
Neighbor        V           AS      MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4              200      37            34              41         0      0        00:28:29          8


Verify R1 to R3:

R1#sh ip bgp sum
<snip>
Neighbor        V           AS      MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
3.3.3.3           4            200       8             7                 41         0     0         00:02:37        8

R3#sh ip bgp sum
<snip>
Neighbor        V           AS      MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
1.1.1.1             4          100      10            12               9          0       0        00:05:35        0

4.       Establish an eBGP secure peering between R3 and R4 using the password CISCO1

R3(config)#router bgp 200
R3(config-router)#neighbor 4.4.4.4 remote-as 200
R3(config-router)#neighbor 4.4.4.4 update-source loopback 0
R3(config-router)#neighbor 4.4.4.4 ebgp-multihop 255
R3(config-router)#neighbor 4.4.4.4 password CISCO1

R4:
R4(config)#router bgp 400
R4(config-router)#neighbor 3.3.3.3 remote-as 200
R4(config-router)#neighbor 3.3.3.3 update-source loopback 0
R4(config-router)#neighbor 3.3.3.3 ebgp-multihop 255
R4(config-router)#neighbor 3.3.3.3 password CISCO1

Verify:

R3#sh ip bgp sum
<snip>
Neighbor        V         AS        MsgRcvd MsgSent   TblVer  InQ OutQ  Up/Down  State/PfxRcd
4.4.4.4            4         400       7                8                 9          0       0        00:03:36        0


R4#sh ip bgp sum
<snip>
Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
3.3.3.3         4          200       8       6        9    0    0 00:03:03        8





No comments:

Post a Comment